Of late the browser has been complaining that it is out of date, and it should be updated. Which is par for the course I guess, anyway, easy enough to fix right?

So first up run the kano updater – and … nothing. No updates required…

Hmmm. Ok – so have a look on google, because lets be honest this is how that works now. I found an article on stackexchange that fit the bill.

sudo apt-get update
sudo apt-get dist-upgrade 
sudo apt-get install -y rpi-chromium-mods

So yay. Hang on. There are a few things that were uninstalled…

I retry the internet and Chromium is now updated, so no warning. Still a nagging worry about the forced uninstall and the reboot proved it. No more dashboard. Nuts.

Ok – fix.

sudo apt-get install kano-dashboard

Now interestingly – there is a dependency on rpi-chromium-mods-kano, which perhaps explains why this broke. Anyway – it also uninstalls the update so back to the original issue.

First lesson: -y is bad, do not use unless you have a very good idea of what you are saying yes to (-y assumes yes on all the questions… so it’s bad).

Second lesson: kano maintenance is harder than I feel it should be…